DÜŞEYARA ( VLOOKUP ) işlevi

Düşeyara işlevi muhtemelen excel in en sevilen fonksiyonlarından biri.
Düşeyara fonksiyonu bir değeri, bir veri setinin ilk kolonunda arayıp başka bir kolonun değerini döndürür. Elimizde bir değer var ve o değere ait diğer bilgiler başka bir tabloda ise kullanılır.

Düşeyara nın sözdizimi şöyledir :

=DÜŞEYARA(aranan_değer;tablo_dizisi;sütun_indis_sayısı;[aralık_bak])

ingilizce excelde;

=VLOOKUP(value_search,table_array,no_index_col,range_lookup))

 

Burada ;

  • aranan_değer          : Tabloda arayıp diğer bilgilerini getirmek istediğimiz değer.
  • tablo_dizisi                : Arama yapacağımız ve bilgi çekeceğimiz tablo. İlk sütun arama yapacağımız sütun olmalı. Ayrıca veri çekeceğimiz sütun da bu aralıkta olmalı
  • sütun_indis_sayısı   : Getirmek istediğimiz verinin tablo_dizisi olarak seçtiğimiz alandaki sütun numarası.
  • [aralık_bak]               : DOĞRU ( TRUE veya 1) seçilirse aranan değer tablo dizisindeki  iki kayıt arasında ise ilk kaydın karşısındaki değeri getirir. Barem tablosundan veri getirmek için kullanılabilir .YANLIŞ (FALSE veya 0)  seçilirse alan aralıkta bulunma değil birebir eşleşme bekleniyordur.  Bu opsiyonun  DOĞRU ( TRUE veya 1) şeklinde kullanımı yok gibidir. Genelde bu kulanım yanlış anlaşılmaktadır

Örnek olarak birkaç ilimizin isminin bulunduğu şu alana bakalım. Bu illerin yanına plaka numaralarını ve nüfuslarını yazmak istiyoruz. Bu bilgiler ise başka bir sayfada bulunuyor

 

duseyara-vlookup-1

 

Plaka ve nüfus bilgilerinin bulunduğu tablo, il-nufus sayfasında bulunuyor;

duseyara-vlookup-2

 

B sütununa bu illerin plaka numarasını getirelim. DÜŞEYARA fonksiyonunun parametrelerini A2 hücresinde bulunan Adana için adım adım yazalım;

  • aranan_değer        : A2  . ( Doğrudan “Adana” da yazabilirdik
  • tablo_dizisi             : ‘il-nufus’!A:K .  il-nufus saydasındaki A:K sütunları. Değerler A5-K81 arasında fakat A:K yazmak pratik açıdan daha uygun
  • sütun_indis_sayısı : 2. istediğimiz değer plaka. Plakalar seçtiğimiz alanın 2. sütununda
  • [aralık_bak]            : YANLIŞ . Aralık kullanmadığımızdan  0 ya da YANLIŞ yazıyoruz

 

düşeyara-vlookup-4

 

Formül şöyle oldu:

=DÜŞEYARA(A2;’il-nufus’!A:K;2;YANLIŞ)

Diğerleri için de bu formülü çoğaltırsak sonuçta şöyle bir görüntümüz olacak;

 

duseyara-vlookup-3

 

Dikkat!

  • Aranan değer, Arama yapılan tabloda bir tane olmalı. Aranan değer birden çok tekrarlanıyor ise excel ilk bulduğu kaydı kullanır
  • Arama ilk sütun üzerinde yapılır
  • Verinin getirileceği sütunlar aramanın yapılacağı sütunun sağında yer almalı. Negatif indis mümkün değildir.
  • Formülü aşağıya sürüklerken tablo_dizisi adresinin aralığı da otomatik olarak kayacaktır. Mesela ilk hücreye tablo dizisi olarak A5:K81 yazar aşağı çekerseniz  ikinci hücre A6:K82 olur. Bunu engellemek için ya A:K şeklinde tüm kolonu seçmelisiniz ya da $A$5:$K81$ şeklinde adresi $ işareti ile yazmalısınız.
  • Değer bulunamaz ise #YOK ( #N/A) mesajı hücrede belirir. Bundan kaçınmak için DÜŞEYARA fonksiyonu EĞERHATA ( IFERROR) fonksiyonu içinde kullanılabilir. Örnek :                  =IFERROR(VLOOKUP($H$1,CHAMPS,2,FALSE),”Bulunamadı”)
  • DÜŞEYARA fonksiyonu büyük-küçük harfe duyarlı değildir! Örnek

    Düşeyara fonksiyonunun büyük -küçük harf duyarlı olmadığını gösteren örnek
    Düşeyara fonksiyonu büyük -küçük harfe duyarlı değildir
  • Tüm parametreler sabit olarak yazılabileceği gibi hücrelere referans da verilebilir. ( Mesela sütun indis sayısı 2 yazmak yerine değeri 2 olan bir hücre seçilebilir). Ayrıca referans hücrelerin adresleri yerine isimlendirilmiş alan ( named range) ismi yazılabilir ( Ör: il-nufus sayfasındaki tablo iller_nufus olarak adlandırılmış olsaydı formülü şu şekilde yazardık : =DÜŞEYARA(A2;iller_nufus;2;YANLIŞ)
  • DÜŞEYARA fonksiyonunda tam metin yazmak yerine joker karakterler ile desen verilebilir. Örnek: Adana yerine Ada* veya Ad*n*  aynı sonucu verir. Excelde joker karakterler ? ve *  karakterleridir. Örnek;

    Düşeyara ile joker karakterlerin ( wildcard) kullanımı
    Düşeyara ( vlookup) ile joker karakterlerin ( wildcard) kullanımı

 

Benzer fonksiyonlar:

  • YATAYARA ( HLOOKUP ) fonskiyonu VLOOKUP fonskiyonunun yatay tabloda çalışan halidir. YATAYARA fonksiyonu, DÜŞEYARA için kullanılan veri setinin transpoz edilmiş (devrik) halini kullanır.

Alternatifleri:

  • KAÇINCI (MATCH) fonskiyonu ve İNDİS (INDEX)fonskiyonu birlikte kullanılarak aynı veri getirilebilir. Bu şekilde aranan değerin tablo_dizisi ‘nin en solunda olması zorunluluğu da ortadan kalkar.Örnek: A2 hücresi için B2 ye yazılan formül şu şekilde olur: =İNDİS(‘il-nufus’!A:K;KAÇINCI(Sayfa4!A2;’il-nufus’!A:A;0);2)
  • ARA ( LOOKUP) fonksiyonu ile çoğu durumda aynı görev yerine getirilebilir.

aralık_bak opsiyonu genelde yanlış anlaşılır ve kullanılmaz.Kullanım amacı biraz daha farklıdır. Bu özelliği kullanarak bir baremden veri çekebiliriz. Örnek  :DÜŞEYARA işlevi ile baremden veri çekme – aralık_bak opsiyonu örnek-